3 Replies Latest reply on Nov 14, 2016 8:30 AM by Shevata Shanmugam

    Histogram from Combined Fields not Publishing to Server

    Jason Nichols

      Hello,

       

      I have a data set with 3 data points that I'm interested in - Item, Site and Inventory. I created a combined field of Item and Site, and then a calculated field of COUNTD([Site & Item (Combined)]). I also created a calculated field for the bins that defines bins between 0 and 10 spaced by 1:

      INT(IF

      ([Inv]) < 1 THEN "0"

      ELSEIF

      ([Inv]) < 2 THEN "1"

      ELSEIF

      ([Inv]) < 3 THEN "2"

      ELSEIF

      ([Inv]) < 4 THEN "3"

      ELSEIF

      ([Inv]) < 5 THEN "4"

      ELSEIF

      ([Inv]) < 6 THEN "5"

      ELSEIF

      ([Inv]) < 7 THEN "6"

      ELSEIF

      ([Inv]) < 8 THEN "7"

      ELSEIF

      ([Inv]) < 9 THEN "8"

      ELSEIF

      ([Inv]) < 10 THEN "9"

      ELSEIF

      ([Inv]) >= 10 THEN "10"

      END)

       

      The goal is to view inventory by distinct Item and Site combinations. When I create a histogram using these, it creates just fine with the desired result:

      However, when I go to publish this to the server, it shows up in the preview, but the sheet is blank (It is also blank when you open it or view it from the server).

      If I try this not using the combined field with just one of the fields (Item for instance), it publishes just fine. Am I doing something wrong when creating the combined fields? Has anyone experienced this before? I have researched and found that when people see disappearing sheets it's mainly caused by filters, but I am not using any filters here.

       

      Thanks,

      Jason

        • 1. Re: Histogram from Combined Fields not Publishing to Server
          Shevata Shanmugam

          Is there any errors while publishing?  How are you publishing the worksheet/workbook, what options do you have selected? Verify Permissions, Data Sources and any other options.

          • 2. Re: Histogram from Combined Fields not Publishing to Server
            Jason Nichols

            Hi Shevata,

             

            There are no errors while publishing. I should have added - this was originally noticed because this histogram was just one part of a dashboard. All other sheets, charts, titles, etc. publish fine on the dashboard. It is just this specific sheet. I simplified the chart as much as possible after identifying that the issue was with the combined fields.

             

            I am publishing using all default options using [Server] -> [Publish Workbook]. The data is an extract from Teradata. There is another worksheet on the dashboard connected to the same data source that displays fine. I'm not sure where to find the other options you're mentioning?

             

            As an aside - one thing I have tried is concatenating the fields in the custom sql query for the data source (rather than using the combined field function within Tableau). This worked to publish but now I cannot use Site and Item individually for action filters from this worksheet for other sheets on the dashboard. When I add Site and Item they are added as ATTR and it looks like I cannot use attributes to filter other sheets? I understand this is a different issue entirely... just trying to find an overall solution.

             

            Thanks for your help,

            Jason

            • 3. Re: Histogram from Combined Fields not Publishing to Server
              Shevata Shanmugam

              Hmm, I will look further. 

              The other options will be available to you when publishing.  I am unsure what version of Tableau you have, but in 10.0 the screen is as such.