5 Replies Latest reply on Oct 24, 2016 8:37 AM by AJ AJ

    Https:// or Certificate issue

    AJ AJ

      As per the screen shot i have the below issue

       

       

      What could be the issue.The certificate on our server has not issue.

        • 1. Re: Https:// or Certificate issue
          Alexander Mou

          Apparently it is a SSL issue.

          Make sure the path to the certificates is correct. or are the certificates still valid?

          • 2. Re: Https:// or Certificate issue
            Obed Tsimi

            It can be a little tricky to troubleshoot this as this could indicate several things with SSL.

             

            Do you use a proxy?

             

            See the possible troubleshooting senarios here

             

            Troubleshooting Mutual SSL Authentication

            • 3. Re: Https:// or Certificate issue
              Brian Vinson

              When you are creating your SSL via tabadmin make sure you use the final domain name that everything is going to sit on (i.e. yoursite.com, company.net, etc.). You'll need to test the SSL from there too since localhost isn't registered.

              • 4. Re: Https:// or Certificate issue
                AJ AJ

                Thank you Obed Tsimi,

                 

                This helped me a bit, I have asked my network team to add the root certificate in the user computer.

                • 5. Re: Https:// or Certificate issue
                  AJ AJ

                  Hi Obed Tsimi,

                   

                  I have looked at the log and found this common error

                  -- resuming normal operations

                  [Mon Oct 17 20:04:12.240040 2016] [mpm_winnt:notice] [pid 5244:tid 724] AH00456: Server built: May  3 2016 13:35:15

                  [Mon Oct 17 20:04:12.240040 2016] [core:notice] [pid 5244:tid 724] AH00094: Command line: 'E:/Tableau Server/10.0/apache/bin/httpd.exe -d E:/Tableau Server/10.0/apache -E E:/Tableau Server/data/tabsvc/logs/httpd/startup.log -f E:/Tableau Server/data/tabsvc/config/httpd.conf'

                  [Mon Oct 17 20:04:12.240040 2016] [mpm_winnt:notice] [pid 5244:tid 724] AH00418: Parent: Created child process 18072

                  [Mon Oct 17 20:04:13.161912 2016] [ssl:warn] [pid 18072:tid 680] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name

                  [Mon Oct 17 20:04:14.177536 2016] [ssl:warn] [pid 18072:tid 680] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name

                  [Mon Oct 17 20:04:14.177536 2016] [mpm_winnt:notice] [pid 18072:tid 680] AH00354: Child: Starting 600 worker threads.

                  [Mon Oct 17 20:13:49.083216 2016] [mpm_winnt:notice] [pid 5244:tid 724] AH00422: Parent: Received shutdown signal -- Shutting down the server.

                  [Mon Oct 17 20:13:57.130111 2016] [mpm_winnt:notice] [pid 18072:tid 680] AH00364: Child: All worker threads have exited.

                  [Mon Oct 17 20:13:57.270730 2016] [mpm_winnt:notice] [pid 5244:tid 724] AH00430: Parent: Child process 18072 exited successfully.

                  [Mon Oct 17 20:14:54.250327 2016] [ssl:warn] [pid 5404:tid 780] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name

                  [Mon Oct 17 20:14:55.312385 2016] [ssl:warn] [pid 5404:tid 780] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name

                  [Mon Oct 17 20:14:55.312385 2016] [mpm_winnt:notice] [pid 5404:tid 780] AH00455: Apache/2.4.12 (Win32) mod_auth_kerb/5.4 mod_auth_sspi/1.0.4 OpenSSL/1.0.2h configured

                   

                   

                  I have asked my Network/Admin team to include the root certificate in the users windows machine. Not sure if it resolves the warning that this beining populated as below.