13 Replies Latest reply on Nov 12, 2016 11:37 AM by Chris Dickson

    Repository stuck on 'Setting Up'

    Chris Dickson

      Hi,

       

      hopefully someone out there with a fix for this, this is a single node 8 core tableau server deployment, it has never been multinode.

       

      My understanding was that 'setting up' was something that happens when you set up a passive repository for failover, however on applying a new licence key and restarting the server the repository is stuck, there are a few flat file extract but not a huge number and the number of users is under 200 (local users) so the repository should be pretty light.

       

      After leaving the server for a few hours we tried cycling the whole machine, which has left us with the repository again stuck 'setting up'.

       

      Any hints would be welcome.

        • 1. Re: Repository stuck on 'Setting Up'
          Nathan Panuco

          Hey Chris!

           

          Since it's a single node install, that rules out a lot of possibilities....any disk space issues? We've seen this crop up in some instances when disk space is running low. The cluster controller logs may also contain some relevant information, although you might need to engage Tableau Technical Support to make sense of them http://www.tableau.com/support/request

           

          Hope this helps!

          1 of 1 people found this helpful
          • 2. Re: Repository stuck on 'Setting Up'
            Chris Dickson

            I have tried to go through the logs, but as you say it is probably best to engage the Tableau bods to make sense of them.

             

            Not likely a space issue, currently 74GB free space.

             

            Thanks.

            • 3. Re: Repository stuck on 'Setting Up'
              Ruthie Petty

              Tableau support helped us with this, to a certain point (much appreciated), and then we had to go back to the company managing our servers.

               

              Kaspersky was still running on the Tableau folders; the data block size was not correct for postgres; and we were getting a lot of system Event 129s that indicated more severe issues. They changed some of the architecture for our storage and it looks like we've stabilized now.

               

              Hope it's an easy fix for you!

              • 4. Re: Repository stuck on 'Setting Up'
                junjappa madirappa

                Hi Chris

                 

                were you able to resolve this issue ? when it fails to load the server preposition does it let you login ?, I have installed beta version on my system and there is sufficient disk space, but when i try to loin it always throw an error message that password is incorrect

                • 5. Re: Repository stuck on 'Setting Up'
                  junjappa madirappa

                  Hi Chris

                   

                  I have been facing the same issue, tried different things couldn't figure out a solution however i tried to go to the server configuration and logged in again without making any changes, when i restart the Tableau server it works fine

                   

                  Before Restart the server

                  Status: RUNNING

                  'Tableau Server Coordination Service 0' (11064) is running.

                  'Tableau Server Search and Browse 0' (12164) is running.

                  'Tableau Server Tabadmin Service 0' (3328) is running.

                  'Tableau Server Data Engine 0' (8380) is running.

                  'Tableau Server Application Server 0' (7284) is running.

                  'Tableau Server Backgrounder 0' (1864) is running.

                  'Tableau Server CacheServer 0' (15720) is running.

                  'Tableau Server Dataserver 0' (13236) is running.

                  'Tableau Server Vizqlserver 0' (2948) is running.

                  'Tableau Server Gateway' (11832) is running.

                  'Tableau Server Cluster Controller' (12648) is running.

                  'Tableau Server Repository' is setting up.

                  'Tableau Server File Store' (6476) is running.

                   

                  D:\Tableau Server\Tableau Server\10.1\bin>tabadmin status

                  Status: RUNNING

                   

                  After restarting the server

                  D:\Tableau Server\Tableau Server\10.1\bin>tabadmin status -v

                  Status: RUNNING

                  'Tableau Server Coordination Service 0' (14540) is running.

                  'Tableau Server Search and Browse 0' (536) is running.

                  'Tableau Server Tabadmin Service 0' (7944) is running.

                  'Tableau Server Data Engine 0' (16564) is running.

                  'Tableau Server Application Server 0' (15908) is running.

                  'Tableau Server Backgrounder 0' (9048) is running.

                  'Tableau Server CacheServer 0' (7548) is running.

                  'Tableau Server Dataserver 0' (7740) is running.

                  'Tableau Server Vizqlserver 0' (14048) is running.

                  'Tableau Server Gateway' (2728) is running.

                  'Tableau Server Cluster Controller' (3220) is running.

                  'Tableau Server Repository' (7192) is running (Active Repository).

                  'Tableau Server File Store' (15928) is running.

                  1 of 1 people found this helpful
                  • 6. Re: Repository stuck on 'Setting Up'
                    Mike Connery

                    @nathan

                     

                    Junjappa,  You mentioned that "when i restart the Tableau server it works fine" - are you talking about restarting the Tableau Server software instance (via tabadmin) or restarting the Windows server?  I am having a very similar issue following a simple 'tabadmin cleanup'  and can't seem to get beyond the "Tableau Server Repository is setting up".  I have tried 'tabadmin stop' then 'tabadmin start', 'tabadmin restart' and also tried restarting my Windows server.  None of these things has had any effect.  Following the start or restart I see the following in the command window:

                     

                    C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin restart

                    ===== Stopping service...

                      -- Service stopped successfully

                    ===== Starting service...

                    Tableau Server not available; check that it is running.

                    ===== Unable to determine if all components of the service started properly. See "tabadmin.log" for more information.

                    Status: RUNNING

                    'Tableau Server Coordination Service 0' (8132) is running.

                    'Tableau Server Search and Browse 0' (4012) is running.

                    'Tableau Server Tabadmin Service 0' (1100) is running.

                    'Tableau Server Data Engine 0' (1420) is running.

                    'Tableau Server Application Server 0' (4028) is running.

                    'Tableau Server Backgrounder 0' (2800) is running.

                    'Tableau Server Backgrounder 1' (6820) is running.

                    'Tableau Server CacheServer 0' (6384) is running.

                    'Tableau Server Dataserver 0' (2820) is running.

                    'Tableau Server Vizqlserver 0' (2016) is running.

                    'Tableau Server Gateway' (1892) is running.

                    'Tableau Server Cluster Controller' (3620) is running.

                    'Tableau Server Repository' is setting up.

                    'Tableau Server File Store' (1784) is running.

                     

                    C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin status

                    Status: RUNNING

                    'Tableau Server Repository' is setting up.

                    • 7. Re: Repository stuck on 'Setting Up'
                      Chris Dickson

                      Hi all,

                       

                      after going back and forth and going through the tableau and windows log files we found an issue with starting the postgres service however running a repair on the postgres install didn't resolve the issue, in the end the only fix was a clean install and restore the last backup of the server.

                       

                      We tried the same thing as you Junjappa and it did not work, glad it did for you.

                       

                      Make sure you all log incidents with the Tableau helpdesk as the more people this affects the more likely they are to look into it in more detail.

                      • 8. Re: Repository stuck on 'Setting Up'
                        Mike Connery

                        I should also note that I am unable to login to Tableau Server either by connecting locally on the server (via localhost) or remotely using the web URL.  In each case it simply says 'Sign in failed.'

                        • 9. Re: Repository stuck on 'Setting Up'
                          Chris Dickson

                          That is because all the login details are held within the repository, without access to it the system cannot authenticate you.

                           

                          This was actually what drew my attention to the repository issue in the first place.

                          • 10. Re: Repository stuck on 'Setting Up'
                            Mike Connery

                            Thanks for the info Chris.   This seems like a pretty major glitch - I'm surprised there aren't more mentions of it.  Its somewhat ironic because I was running the tabadmin cleanup in preparation to do a backup - never got that far.  Fortunately we have a recent one to work with if needed.  I've opened a support request, and I'll post the outcome here.

                            • 11. Re: Repository stuck on 'Setting Up'
                              Mike Connery

                              OK - I got a reply from Tableau support with some suggested troubleshooting, which appears to have been successful.  Here are the details:

                               

                               

                              Subject: Case# 02498693: Tableau Server restart stuck on 'Tableau Server Repository' is setting up'. [Active] [ ref:_00D30XvE._5003216SYSU:ref ]

                               

                              Hello,

                               

                              Your case #02498693 has been updated. The new comment is:

                               

                              Hi Michael,

                               

                              Thank you for contacting Tableau Technical Support.

                               

                              As a troubleshooting step, please try the following:

                               

                              Tabadmin stop

                              Tabadmin cleanup --reset-coordination

                              Tabadmin start

                               

                              **if the repository is still showing as setting up, please try the following:

                               

                              tabadmin stop

                              tadadmin set clustercontroller.pgsql_connection_timeout_ms 12000 tabadmin config tabadmin start

                               

                              Thank you for your patience and understanding.

                               

                              Please find your case summary below. To update this case via email, please reply to this message.

                               

                              ======================================================================================================================================================================

                               

                              SO – the second command suggested appears to have been successful (tabadmin set clustercontroller.pgsql_connection_timeout_ms 12000 ) – the Tableau Server service has started successfully this time without indicating the “ ‘Tableau Server Repository’ is setting up” message.

                              Checking my ability to login – that is now successful as well.

                               

                              Here’s my command window session showing the results of each command for reference:

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin stop

                              ===== Stopping service...

                                 -- Service stopped successfully

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin cleanup --reset-coordination

                              ===== The service is not running, so http_request logs will not be purged.

                              ===== Removing service logs.

                              ===== Removing coordination transaction logs.

                              ===== Removing tempdir contents at C:/ProgramData/Tableau/Tableau Server/data/tabsvc/temp

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin start

                              ===== Starting service...

                              Tableau Server not available; check that it is running.

                              ===== Unable to determine if all components of the service started properly. See "tabadmin.log" for more information.

                              Status: RUNNING

                              'Tableau Server Coordination Service 0' (536) is running.

                              'Tableau Server Search and Browse 0' (6316) is running.

                              'Tableau Server Tabadmin Service 0' (1180) is running.

                              'Tableau Server Data Engine 0' (5708) is running.

                              'Tableau Server Application Server 0' (6988) is running.

                              'Tableau Server Backgrounder 0' (5932) is running.

                              'Tableau Server Backgrounder 1' (7116) is running.

                              'Tableau Server CacheServer 0' (6156) is running.

                              'Tableau Server Dataserver 0' (4228) is running.

                              'Tableau Server Vizqlserver 0' (4020) is running.

                              'Tableau Server Gateway' (3996) is running.

                              'Tableau Server Cluster Controller' (4908) is running.

                              'Tableau Server Repository' is setting up.

                              'Tableau Server File Store' (5036) is running.

                               

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin status

                              Status: RUNNING

                              'Tableau Server Repository' is setting up.

                               

                               

                              [ OK - so the first suggested command did not work, trying the second ]

                               

                              ========================================================================================================================================

                               

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin stop

                              ===== Stopping service...

                                 -- Service stopped successfully

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin set clustercontroller.pgsql_connection_timeout_ms 12000

                                 -- value for key clustercontroller.pgsql_connection_timeout_ms has been set

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin config

                              ===== Wrote configuration files to C:/ProgramData/Tableau/Tableau Server/data/tabsvc/config

                                 -- Web data connectors were distributed to all gateways.

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin start

                              ===== Starting service...

                                 -- Service was started successfully

                               

                              C:\Program Files\Tableau\Tableau Server\10.0\bin>tabadmin status

                              Status: RUNNING

                              3 of 3 people found this helpful
                              • 12. Re: Repository stuck on 'Setting Up'
                                junjappa madirappa

                                Chrs

                                 

                                Thank you so much for the info, finally the greatest mystery has been solved, thank you for other members know about the solution

                                 

                                Regards

                                Junjappa

                                • 13. Re: Repository stuck on 'Setting Up'
                                  Chris Dickson

                                  Thanks for sharing Mike,

                                   

                                  we tried the first command as we new about it but the second one is completely new to me, who knew simply extending the timeout on postgres would resolve the issue, if it comes up again i'll try that first.

                                   

                                  Thanks

                                   

                                  Chris