1 Reply Latest reply on Aug 29, 2016 6:19 AM by Rahul Verma

    Packaged File Size Issue

    Ben Adam

      Hi,

       

      I am trying to reduce the size of a packaged Tableau file but am not having much luck.

      The dashboard I am using is connected to 2 data sources. I have tried creating an extract, hiding unused fields, using the extract option but for some reason it won't decrease the file size when I convert it to a packaged file.

      I've been able to reduce the file size previously but it is no longer working.

       

      Any suggestions?

       

       

       

      Thanks,

      Ben

        • 1. Re: Packaged File Size Issue
          Rahul Verma

          Hi Ben

          Three things can definitely help:

           

          On the Extract Data screen:

          1.If not all the data will be used, then apply a filter.  for example: There's no need to pull records from   2011 if you are only reporting from 2012 on.

           

          2. Select the "Hide Unused Fields" option. This will hide any fields that are not used in any view in the workbook. Any unused field will not be included in the extract.

           

          3.Check Aggregate Data for Visible dimensions.  This will cause the extract to aggregate the raw records into summary data for the extract (at the highest level of aggregation possible given what is currently visible in each view).

           

          Any one of these or some combination can dramatically reduce extract size.  Be aware that #1 and #3 have the potential for impacting the functionality of your views (if you want to be able to drill into lower levels of detail or see data that was excluded in the filter).  #2 is relatively safe to always apply.

           

          4. Upgrade to Tableau's latest version as it has far better compression for text fields in extracts.

          Further, you can follow the link: http://kb.tableau.com/articles/howto/reducing-the-size-of-packaged-workbooks

          Regards,

          Rahul