1 Reply Latest reply on May 10, 2016 11:08 AM by Matt Gizbert

    Tableau Server extract lost connection to datasource

    Johan De Groot

      Hi,

       

      since last week (I think a couple of days) some Tableau datasources have been 'broken'.

       

      These were Mysql dataconnection, with a daily refresh on the datasource-extract. This worked fine, but since a couple of days these datasources stopped working.

      When I try to do a 'refresh from source', I get a message "Could not find the referenced file 'extract.....' instead of the normal 'connect to database' login option.

       

      When downloading the datasource ('create local copy') I can download the tdsx file, but when I edit this it opens a dialog to search for the corresponding (not existing) TDE file, while the usual 'edit dataconnection' dialog should show up.

      Live datasources on Tableau Server (without a scheduled extract) work fine.

       

      It seems like Tableau Server lost the connection to the original datasource, and only connects to the extract.

       

      Does anyone else have the same problem - and more important: can this be fixed?

       

      Kind regards,

      Johan

        • 1. Re: Tableau Server extract lost connection to datasource
          Matt Gizbert

          Hi Johan,

           

          Which version of Tableau Server are you running?

           

          If we can use just one example of this issue, can you try downloading the workbook from Server and opening it in Desktop? Once in Desktop it should ask you to "find" the missing extract. This will let you either replace the data source with the new extract, or change to a live connection (which you can then re-extract in the workbook). Once the connection is set properly in Desktop you should be able to publish to Server without issue.

           

          Does that workflow work for a test example? This will help narrow down what could be going on.

           

          Matt