8 Replies Latest reply on Jan 20, 2016 4:44 PM by Yuliang Liao

    Tableau server wont start ERROR

    Leonardo Astudillo

      Hi all,

       

      I am doing a installation of Tableau server 9.1 64bits  it all looks ok when performing the install wizard, but when the install process is about to finish it says that Tableau Server cant START.

       

       

      I check the logs and i got this:

       

       

      ------notify-tabadmin

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/META-INF/main.rb:36:in `require'

      <script>:3:in `(root)'

      2015-09-30 10:32:30.471 -051800_FATAL_10.0.10.11:srur1tbl01_:_pid=2908_0x1bc776b7__user=__request=__ Unable to init component Components::Vizportal (6 of 19): MultiCommand::ReportableError: Error deploying new solr war file. Running processes may be using these files. Make sure Server is stopped before trying this again. If this is happening during an installation, cancel the installation, uninstall Tableau Server, and then reboot Windows before trying again to ensure any orphaned processes are stopped. - Permission denied - C:/ProgramData/Tableau/Tableau Server/data/tabsvc/searchserver/0/webapps/solr.war

       

       

       

       

      tabadmin.log

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/lib/component.rb:564:in `task_init'

      org/jruby/RubyArray.java:1615:in `each'

      org/jruby/RubyEnumerable.java:951:in `each_with_index'

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/lib/component.rb:529:in `task_init'

      file:C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/lib/service/init.rb:336:in `run'

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/lib/service.rb:599:in `init'

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/lib/commands/initialize.rb:54:in `run'

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/lib/multicommand.rb:231:in `dispatch'

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/bin/tabadmin.rb:29:in `(root)'

      org/jruby/RubyKernel.java:1058:in `load'

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/bin/tabadmin.rb:1:in `(root)'

      org/jruby/RubyKernel.java:1033:in `require'

      file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/META-INF/main.rb:36:in `require'

      <script>:3:in `(root)'

       

       

      THIS ERROR

      Error deploying new solr war file. Running processes may be using these files. Make sure Server is stopped before trying this again. If this is happening during an installation, cancel the installation, uninstall Tableau Server, and then reboot Windows before trying again to ensure any orphaned processes are stopped. - Permission denied - C:/ProgramData/Tableau/Tableau Server/data/tabsvc/searchserver/0/webapps/solr.war

       

       

      Now i am using the Administrator Account to run the installer and also i am using the Administrator account in the configuration dialog of Tableau Server.

       

       

      i had issued the following commands:

      tabadmin.exe init

      tabadmin.exe start

       

       

      Why it says permission denied  if i am using the Admin account i also did a reboot of windows and start a clean install and also fail.

       

      A curious output when i execute tabadmin init is this :

       

      PS C:\Program Files\Tableau\Tableau Server\9.1\bin> .\tabadmin.exe init

      ===== Initializing Tableau Server File Store remotely   ----------------- FILE STORE REMOTELY ? i am doing a local install

      ===== Setting worker0.dataserver.procs=1 for optimum performance on this hardware

      ===== Setting worker0.vizqlserver.procs=1 for optimum performance on this hardware

        *** Error during restore: Component::InitError 'Unable to init component Components::Vizportal (6 of 19): MultiCommand

      ::ReportableError: Error deploying new solr war file. Running processes may be using these files. Make sure Server is st

      opped before trying this again. If this is happening during an installation, cancel the installation, uninstall Tableau

      Server, and then reboot Windows before trying again to ensure any orphaned processes are stopped. - Permission denied -

      C:/ProgramData/Tableau/Tableau Server/data/tabsvc/searchserver/0/webapps/solr.war'

       

      ALSO i check the comun procees of TABLEU server this link Tableau Server Processes none of those are loaded on Windows.

       

       

      Please any help will be appreciated

      Rafael E Rumbos S

        • 1. Re: Tableau server wont start ERROR

          Hey Leonardo,

           

          If you're looking for immediate assistance, I would contact support@tableau.com. Otherwise, I have a few questions:

           

          1. Are you restoring from a backup?

          2. Have you tried restarting the machine?

          3. Does the Run-As user have read/write permission to the install directory?

          • 2. Re: Tableau server wont start ERROR
            Leonardo Astudillo

            ----REPLY------

            1)  Not restoring backup

            2) Yes i rebooted Windows

            3) I am using THE "Administrator" Windows Account so i guess it does have permissions.

             

            Thanks

            • 3. Re: Tableau server wont start ERROR

              I would try working through the section of this article (Run As user issues often lead to installation and start-up problems):

               

              http://onlinehelp.tableau.com/current/server/en-us/help.htm#runas.htm

              • 4. Re: Tableau server wont start ERROR
                Leonardo Astudillo

                any other comments will be appreciated, thanks

                • 5. Re: Tableau server wont start ERROR

                  While waiting for other comments I would definitely contact support@tableau.com and reference this post.

                  • 6. Re: Tableau server wont start ERROR
                    Gordon Young

                    HI Leonardo, were you able to get a resolution? We attempted to upgrade our Tableau server and ran into the exact same issue as you described.

                     

                    We have also sent a contact into support.

                     

                    Gord

                    • 7. Re: Tableau server wont start ERROR
                      Leonardo Astudillo

                      Hello,

                       

                      Disable your antivirus software before install tableau.

                       

                       

                      • 8. Re: Tableau server wont start ERROR
                        Yuliang Liao

                        I got this error and was able to pass it.

                         

                        Here's what I did.

                         

                        BTW, I am only getting this error when I am adding one or more worker node to the primary, starting with the primary single node. 

                         

                        1.  Lets say I have a single node tableau server call serverd

                        2.  I have two other workers call serverc and serverb

                        3.  when trying to add serverb or/and serverc to serverd as a cluster, it gave me the above error with tabadmin log

                         

                        file:/C:/Program Files/Tableau/Tableau Server/9.1/bin/tabadmin.jar!/META-INF/main.rb:36:in `require'

                        <script>:3:in `(root)'

                         

                        what I did was to ignore the error and went ahead added the workers in the tableau configuration screen, hit cancel and started the server.  When I did tabadmin status -v, I got:

                         

                        serverd

                        Status: DEGRADED
                        'Tableau Server Search Service' (3128) is running.
                        'Tableau Server Data Engine 0' (1676) is running.
                        'Tableau Server Tabadmin Service 0' (5004) is running.
                        'Tableau Server Vizqlserver 0' (6040) is running.
                        'Tableau Server Backgrounder 0' (7896) is running.
                        'Tableau Server CacheServer 0' (6876) is running.
                        'Tableau Server Dataserver 0' (5496) is running.
                        'Tableau Server Application Server 0' (4788) is running.
                        'Tableau Server API Server 0' (3920) is running.
                        'Tableau Server Coordination Service 0' (1976) is running.
                        'Tableau Server Search and Browse 0' (3644) is running.
                        'Tableau Server Gateway' (3980) is running.
                        'Tableau Server Cluster Controller' (1476) is running.
                        'Tableau Server Repository' is stopped.
                        'Tableau Server File Store' is stopped.

                        serverb:

                        Status: DEGRADED
                        'Tableau Server Data Engine 0' (4324) is running.
                        'Tableau Server Vizqlserver 0' (4772) is running.
                        'Tableau Server CacheServer 0' (8488) is running.
                        'Tableau Server Dataserver 0' (5404) is running.
                        'Tableau Server Application Server 0' (4416) is running.
                        'Tableau Server API Server 0' (5356) is running.
                        'Tableau Server Coordination Service 0' (2620) is running.
                        'Tableau Server Search and Browse 0' (7048) is running.
                        'Tableau Server Gateway' (6016) is running.
                        'Tableau Server Cluster Controller' (9104) is running.
                        'Tableau Server Repository' is stopped.
                        'Tableau Server File Store' is stopped.

                        serverc:

                        Status: RUNNING
                        'Tableau Server Backgrounder 0' (2544) is running.
                        'Tableau Server Backgrounder 1' (2044) is running.
                        'Tableau Server CacheServer 0' (1068) is running.
                        'Tableau Server Coordination Service 0' (2500) is running.
                        'Tableau Server Gateway' (1344) is running.
                        'Tableau Server Cluster Controller' (2536) is running.

                         

                        So it seems like even with the error, the server took the settings.  As you can see, the repository and file store had issues. 

                         

                        'Tableau Server Repository' is stopped.

                        'Tableau Server File Store' is stopped.

                         

                        After this, I stopped and did a no-config restore from a last known good backup, and started the server, and I never have this problem again.

                         

                        Here are my steps again.

                         

                        1.  Add my worker nodes in tableau configuration screen

                        2.  Ignore the error after hitting okay

                        3.  Hit cancel to exit the tableau configuration screen

                        4.  Start tableau server c:\tabadmin start

                        5.  verify that the setting applied (by degraded) by doing a c:\tabadmin status -v

                        6.  Stop the server c:\tabadmin stop

                        7.  Restore a no-config last known good backup  c:\tabadmin restore --no-config c:\last_known_single_server_backup

                         

                        That's it, and this was in version 9.0.  Good Luck.

                        2 of 2 people found this helpful