4 Replies Latest reply on Nov 23, 2015 1:57 PM by Jayesh Patel

    We are trying to install Sparkler on same server as Tableau. We are getting below error. We have JDK 7 installed. java.lang.UnsupportedClassVersionError

    Amar Patil

       

      We are trying to install Sparkler on same server as Tableau. We are getting below error. We have JDK 7 installed.

       

      Caused by: java.lang.UnsupportedClassVersionError: com/tsi/bizsys/sparkler/config/SparklerConfig : Unsupported major.minor version 51.0 (unable to load class com.tsi.bizsys.sparkler.config.SparklerConfig)

       

                      at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2963)

       

                      at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1212)

       

                      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1692)

       

                      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1573)

       

                      at org.springframework.util.ClassUtils.forName(ClassUtils.java:247)

       

                      at org.springframework.beans.factory.support.AbstractBeanDefinition.resolveBeanClass(AbstractBeanDefinition.java:395)

       

                      at org.springframework.context.annotation.ConfigurationClassPostProcessor.enhanceConfigurationClasses(ConfigurationClassPostProcessor.java:367)

       

                      ... 22 more

       

       

      Any ideas please.