8 Replies Latest reply on Apr 30, 2015 7:09 AM by Toby Erkson

    Unable to publish reports after upgrade to v9

    James Lawrence

      Since upgrading desktop and server to V9 the other day we are not able to publish any reports. when I look at the server app, there are no projects listed. I tried to re-create one and receive a message stating the project already exists.

      has anyone else had this issue and able to help?

      I have opened a call but no response since Thursday.

       

      Thanks

        • 1. Re: Unable to publish reports after upgrade to v9
          Matt Coles

          Sorry you're having this issue, James.

           

          Can you access the Admin Status page? Does it show all processes as green (up)?

          On the Status page, scroll toward the bottom and click "Rebuild Search Index". Typically when you can't navigate to content in 9.0 (but the content is still there), it is an issue with the search index, or the search service.

           

          It's definitely worth following up with Support, even if doing that resolves your issue, as we'd love to prevent others from encountering the same issue.

           

          thanks!

          • 2. Re: Unable to publish reports after upgrade to v9
            James Lawrence

            Thanks for the reply Matt,

             

            I tried the index rebuild but has returned an error that don’t tell you anything other than an error occurred.

            what I have noticed is that the temp project I created yesterday so people can publish and was there a minute ago has now also disappeared after trying the index rebuild.

            sounds like you were I on the correct path so thank again

             

            James

            • 3. Re: Unable to publish reports after upgrade to v9
              Matt Coles

              Yes, I'd say if you tried the index rebuild and it couldn't perform it, you've confirmed that the issue is related to the index. In times past restarting Tableau Server has corrected this issue for me (though you can be sure I always make sure Support has the data they need so Dev can prevent these problems in future builds). I'd recommend giving it that a shot. Note that it might take about five minutes to rebuild the index after your restart.

              • 4. Re: Unable to publish reports after upgrade to v9
                James Lawrence

                Hi Matt,

                 

                finally got an engineer to contact me but they were unsuccessful in finding a fix. we re-installed the software and backups but no joy. Has now raised to a P1.

                will keep you updated on progress in case anyone else has this issue

                Thanks again for your help. much appreciated

                James

                • 5. Re: Unable to publish reports after upgrade to v9
                  Matt Coles

                  Thanks, hopefully they can resolve it quickly for you!

                  • 6. Re: Unable to publish reports after upgrade to v9
                    Zach Yuzer

                    Sounds like support is helping. One thing to note:

                     

                    Do not use the rebuild search index in 9.0 like you did with previous tableau versions. Much more of the internals and vizportal features use SOLR search and running the index will cause views, datasources, users, projects and more to dissapear as they are re-indexed.

                     

                    The new process for this is to simply restart tableau server.

                     

                    From the latest docs:

                     

                    "If indexing is incomplete or an issue is due to an index that needs to be rebuilt, restarting Tableau Server will address the problem. The Browse & Search index is automatically rebuilt when Tableau Server starts.

                    Note: The recommended method for rebuilding the Search & Browse index is to restart Tableau Server. Using the Rebuild Search Index button on the Status page can result in unexpected behavior for users. Content may disappear and then reappear as it is re-added to the index."

                    • 7. Re: Unable to publish reports after upgrade to v9
                      Zach Yuzer

                      What is the error message received when you try to publish?

                       

                      Also can you provide the specs on teh server? number of cores, RAM, and pagefile size.

                      • 8. Re: Unable to publish reports after upgrade to v9
                        Toby Erkson

                        Zach Yuzer wrote:

                         

                        ...

                        Do not use the rebuild search index in 9.0 like you did with previous tableau versions. Much more of the internals and vizportal features use SOLR search and running the index will cause views, datasources, users, projects and more to dissapear as they are re-indexed.

                         

                        The new process for this is to simply restart tableau server...

                        I don't think I like this new indexing method   It takes several minutes for our 8.3 Server to restart and our environment isn't very big at all.