1 Reply Latest reply on Dec 24, 2014 1:22 PM by SUSHMIT ROY

    8.1  + MySql  update  error

    Michel Caissie

      Hi all,

       

      I just updated Tableau Desktop to  8.1 64bit.  At first I thought I would need the  MySQL 64bit driver version so I installed it.

       

      The problem is I can't connect and refresh any existing workbook anymore.

       

      After checking on the Drivers page , I saw that i still needed the 32bit version of the driver so I reverted back with no success.

       

      After a bunch of combination  8.0 32bit,  8.1 32bit,   8.1 64bit,   drivers   5.2.6,  5.2.5,   5.1.13 (all 32bit),   with multiple reboots i am still having the same problem.

       

      Basically, the server refused the connection for the following reason

       

      [MySQL][ODBC 5.2(a) Driver]Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)

       

      I was able to reproduce the problem using MySQL workbench.  I have a setting "Use the old Authentication protocol",  which eliminates the problem when set.

       

      So the question is ; How to force Tableau to force the connection to Use the old Authentication protocol ,  and why was it set that way prior to my updates, and why doesn't it connect that way  using a fresh install.

       

      Nothing have change on the server side, and i have the same problem on multiple instance of servers.

       

      I have a case open  , but if anyone got this problem in the past and came with a solution , i would appreciate having the info.

       

      Thanks

      Michel