2 Replies Latest reply on Jun 19, 2013 10:42 AM by Robert Morton

    "Measures with an aggregation that is not SUM, MIN or MAX are in use" error message

    Loran Levy

      Hi,

       

      After I run a query with a "Count Distinct" command on live connection, I'm trying to do an aggregated Extract to the data.

      When I do that I get the following error message:

      ""Measures with an aggregation that is not SUM, MIN or MAX are in use: CNTD()".

       

      Could someone please advise what this error message means?

       

      Thanks,

      Loran

        • 1. Re: "Measures with an aggregation that is not SUM, MIN or MAX are in use" error message
          Tracy Rodgers

          Hi Loran,

           

          A couple of questions:

           

          1. What is the data source that you're connecting to?

           

          2. When you say

          After I run a query with a "Count Distinct" command on live connection,

          what do you mean? Is it a measure that is being placed on the view? Is it in a calculated field?

           

          3. Can you post a screenshot of the error message?

           

          -Tracy

          • 2. Re: "Measures with an aggregation that is not SUM, MIN or MAX are in use" error message
            Robert Morton

            Hi Loran,

             

            It sounds like you may be attempting to create your Extract with the data aggregated / rolled up for visible dimensions. In doing so, the resulting extract would not contain the fine-grained details needed to compute a distinct count. Try creating your extract without any aggregation to see if that addresses the problem. If you must pre-aggregate the data when creating the extract, you'll need to do the following:

             

            • create a new worksheet
            • drag the field that you wish to count distinct, and drop it as a dimension on the filter shelf
            • with zero items selected in the filter dialog, click OK to accept the filter
            • place the field as a dimension in your worksheet
            • try creating the extract again with the same settings you used before. Note that this time the extract will be much larger and may take much longer to process.

             

            I hope this helps,

            Robert