2 Replies Latest reply on Feb 4, 2013 10:28 PM by Chaitanya Deshpande

    Hyperlink issue



      My problem is that i having a excel sheet with hyperlink column and every row of that column links to different files in shared folder,

      I used Actions -->add new URL feature and used the file:/// prefix as the beginning of the URL in the URL action to make "links to files" work.


      where columnA has the URL value in it.


      Actually the columnA has the URL value built from multiple fields and customized text

      eg -

      'abc-efd-01.bbb.xxx.com\xxeng\xxxOpera\xxReporting\xxx_Weekly\xxxx_Documents\'+[ddate]+'\xxx_Site_xxx\xxxx\' +upper(xc_ENTITY) + '_abc_xxx_xxxl_'+TASK_ID+'.pdf'

      whenever i hit test link i see the below link with "\\" double slashes in between the text not sure why it happens and moreover the link doesn't work.

      But ideally without the double slashes the link works on the browser.

      file:\\abc-efd-01.bbb.xxx.com\\xxeng\\xxxOpera\\xxReporting\\xxx_Weekly\\xxxx_Documents\\2010-05-03\xxx_Site_xxx\xxxx\ XXXXXXX_abc_xxx_xxxL_ABDCD12128610.pdf

        • 1. Re: Hyperlink issue
          Joshua Milligan



          Maybe I'm not following you, but what if you add two slashes to the front of the path?


          Like this:


          '\\abc-efd-01.bbb.xxx.com\xxeng\xxxOpera\xxReporting\xxx_Weekly\xxxx_Documents\'+[ddate]+'\xxx_Site_xxx\xxxx\' +upper(xc_ENTITY) + '_abc_xxx_xxxl_'+TASK_ID+'.pdf'


          It might also be helpful if you could post a packaged workbook or at least some screenshots.  It's kind of hard to understand the context of this problem or if there is another issue in play.



          • 2. Re: Hyperlink issue
            Chaitanya Deshpande


            If I understand you correctly, you want a functionality to open the hyperlink when user select the "ColumnA" value.

            In that case, just provide the <ColumnA> as value under URL and that should work. You don't have to use the "file:\\."


            Secondly, when you click on "Test Link", \\ are appearing in between the text because "\\" is default "Delimiter Escape". If you do not want "\\" to appear, select the check box "Allow multiple values" from the "URL Options" and delete "\\" from the delimiter.


            I hope this works.