1 Reply Latest reply on Jan 31, 2013 8:57 AM by Catherine Rivier

    Trying to connect 2 data table, but it doesn't seem to connect correctly

    Kenneth Ho

      Can anyone please help me with this connection?  I tried to connect the field, but i think Tableau can't recognize and can't give me the correct job code.  Please take a look at my worksheet at problem tab, it is where the problem is.

       

      Also, I am trying to embed the detail information, which is the problem tab information under view data when user click on the filter at Dashboard 1.  Is it possible that I can have Tableau display detail info by filter at the dashboard?  if I can do it, please let me know how.  Thanks

        • 1. Re: Trying to connect 2 data table, but it doesn't seem to connect correctly
          Catherine Rivier

          Hi,

          So first thing, this looks like internal/sensitive data to a company.  You might want to repost with a sample workbook - it might not be a good idea to share this on this public forum....

           

          With that in mind, I'm just going to give you general advice based on your dashboard, and trying to link these Primary/Secondary data sources.

          1. Instead of using Custom Data Relationships, try changing the name of your fields in each view so they automatically link.  Your Data field wasn't linking, for example, because it wasn't in your custom list.  So for example with your second data connection I created fields:
              1. Area: [area]
              2. Schwab Organization: [org]
              3. Date: DATE([ts_date])
          2. After renaming, switch your fields to be automatically linked (Data - Edit Relationships, then select Automatic)
          3. Remember for any view that you're linking 2 data sources, you MUST have the linking field from your Primary source somewhere in your view - either in the Columns/Rows, or the Level of Detail.
          4. In your particular case, try reversing which data source you're using as the Primary, and which you're using as the Secondary.  You have multiple job_codes for each Area in your Secondary connection, and those aren't showing up because it turns into a * in aggregation if multiple records exist.  If you instead use your second data source as the Primary, it will show all of those values.  Essentially Tableau treats your Primary source as a normal source, and aggregates your Secondary, so always make sure you choose the right combination.  Doing this should also fix your final problem.

           

          Hope this helps a bit, and again, it might be a good idea to change your sample workbook to be generic!

           

          Catherine