1 Reply Latest reply on Aug 15, 2012 6:23 AM by vidalreyes0

    Tableau Data Engine Error: 4: bad node type

      Reap extract.png

       

      Hi, the tableau server is showing the  error above, that is causing error in Windows server like is detailled below, I was searching about this topic, but I couln't found nothing.

       

       

      2012-08-15 07:00:26,241_level=FATAL_server=192.165.1.211:

      SERVER_service=backgrounder:_pid=1508_tid=0x221c1fc_user=_session=_request=_context=_message=Vizql::DataSourceException: Tableau Data Engine Error: 4: bad node type

       

       

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/app/models/vizql/session_local.rb:184:in `DeleteExtracts'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/app/models/vizql/session_local.rb:184:in `reap_extract'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/app/models/vizql/session_local.rb:165:in `reap_extracts'

      (__DELEGATION__):2:in `each'

      (__DELEGATION__):2:in `__send__'

      (__DELEGATION__):2:in `each'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/app/models/vizql/session_local.rb:163:in `reap_extracts'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/app/models/vizql/session_local.rb:989:in `with_session'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/app/models/vizql/session_local.rb:162:in `reap_extracts'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/app/models/vizql/extracts.rb:36:in `reap_extracts'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/workers/reap_extracts_worker.rb:27:in `execute'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/backgrounder.rb:127:in `run'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/backgrounder.rb:379:in `run'

      C:/EXERB_ROOT/builds/tableau-6-1/tableau-6-1.11.0724.1830/workgroup/wgapp/backgrounder.rb:398

        • 1. Re: Tableau Data Engine Error: 4: bad node type
          Russell Christopher

          Hey Vidal --

           

          While I'm not in support, I've never seen this error message before. I did a quick spin through our bug database and our internal knowledge base looking for the error "bad node type" and came up empty.

           

          It appears you've run into something new and interesting. Sorry.

           

          I'd recommend you go ahead and open up a case with Technical Support.

          1 of 1 people found this helpful