3 Replies Latest reply on May 2, 2012 11:49 AM by Matt York

    web page not loading

    Chirag S

      I have embedded google widget code in a html page. I am trying to access that html page using web object in tableau. But it giving script execution error and not loading the page and when I paste the same url in the web browsers, page is loading correctly. I am not sure what is causing the error to load the page in tableau framework.

      Thanks in Advance

      CMS

        • 1. Re: web page not loading
          Matt York

          Hey Chirag,

           

          Are you using Google Fusion Tables? If so, they have a known bug with certain versions of Internet Explorer.

           

          https://groups.google.com/group/fusion-tables-users-group/browse_thread/thread/e57d1b1370417ad7?pli=1

           

          I'm not aware of a workaround until Google fixes the bug, but you can still upload the viz to Tableau Server or Tableau Public and the web object will load in most browsers.

           

          Matt

          • 2. Re: web page not loading
            Chirag S

            Following is the link to the google insights page from which I am picking the widget code to embed.

            http://www.google.com/insights/search/#cat=0-67&q=yahoo&date=today%2012-m&cmpt=q

             

            I am using google provided embed code in the blank html. When I open html (coded by me) on internet explorer it works perfectly fine but with tableau web object it is not loading.

            • 3. Re: web page not loading
              Matt York

              Internally, Tableau is using an older version of Internet Explorer. If you are using IE9, you can simulate the browser that Tableau uses by hitting f12 then changing the "Document Mode" at the top of the F12 window to "Internet Explorer 7 standards".

               

              I copied the embed code from the Google Insight widget into an html page, loaded the page in IE9, then viewed in in "Internet Explorer 7 standards". The widget does not load and I get these two errors:

               

              SCRIPT87: Invalid argument.

              SEC7112: Script from http://... was blocked due to mime type mismatch

               

              Two problems:

              1. The widget doesn't work with IE7. Google may not fix these problems because they no longer support IE7.

              2. Tableau is using an outdated version of IE that not even Google supports.

               

              Options from here:

              1. You can still use the web zone and it will work fine when people are looking at a Tableau Public/Tableau Server view through a browser other than IE7.

              2. You can ask the Google Insights team to fix the problem with IE7

              3. You can open a case with Tableau Support to update the browser version. The more they here of a problem, the more likely it is to land in a maintenance release.

               

              Hope that helps!