7 Replies Latest reply on May 2, 2019 9:13 AM by Bobby Reynolds

    VizAlerts on Tableau Server 2018.3.3

    Bobby Reynolds

      I have just recently installed VizAlerts on our Tableau Server and the installation and testing went fine. But when I tried to use VizAlerts on one of our viz, it doesn't seem to run and send out the viz. When I run vizalerts.exe from the server, I do get the visualization e-mailed out. I'm stuck on how to diagnose the problem and was hoping someone could give me some ideas. The 'STLF Forecast Error by Area per Day' is the sheet in the attached workbook that we are trying to mail out as a test.

        • 1. Re: VizAlerts on Tableau Server 2018.3.3
          Matt Coles

          Hi Bobby. Can you provide more details around the testing you did that works, and how you are trying to run it now that isn't? We'll also need the log output from the execution of VizAlerts to help troubleshoot.

          • 2. Re: VizAlerts on Tableau Server 2018.3.3
            Bobby Reynolds

            The testing steps in the installation guide named 'Can VizAlerts Connect','Simple Alert Test' and 'Put VizAlerts through its paces test' all worked. My next step was trying to get VizAlerts working against one on my visualization that mentioned in the earlier note. I see the following sit up in ScheduledTriggerViews but it seems like nothing runs. Nothing is emailed out, I no administrative emails, and there is nothing in the logs on tableau server. When I run vizalerts.exe on the tableau server, I do get the this visualization and information is populated in the logs.

            ScheduledTriggerViews.JPG

            Thanks Matt.

             

            • 3. Re: VizAlerts on Tableau Server 2018.3.3
              Bobby Reynolds

              The testing steps in the installation guide named 'Can VizAlerts Connect','Simple Alert Test' and 'Put VizAlerts through its paces test' all worked. My next step was trying to get VizAlerts working against one on my visualization that mentioned in the earlier note. I see the following sit up in ScheduledTriggerViews but it seems like nothing runs. Nothing is emailed out, I no administrative emails, and there is nothing in the logs on tableau server. When I run vizalerts.exe on the tableau server, I do get the this visualization and information is populated in the logs.

              <https://community.tableau.com/servlet/JiveServlet/showImage/2-914041-644537/ScheduledTriggerViews.JPG>

              Thanks Matt.

               

               

              Attaching the vizalerts.log here since I couldn’t see how to do it from the web site.

              • 4. Re: VizAlerts on Tableau Server 2018.3.3
                Bobby Reynolds

                The testing steps in the installation guide named 'Can VizAlerts Connect','Simple Alert Test' and 'Put VizAlerts through its paces test' all worked. My next step was trying to get VizAlerts working against one on my visualization that mentioned in the earlier note. I see the following sit up in ScheduledTriggerViews but it seems like nothing runs. Nothing is emailed out, I no administrative emails, and there is nothing in the logs on tableau server. When I run vizalerts.exe on the tableau server, I do get the this visualization and information is populated in the logs.

                ScheduledTriggerViews.JPG

                 

                Thanks Matt.

                • 5. Re: VizAlerts on Tableau Server 2018.3.3
                  Matt Coles

                  Okay, so far everything is looking fine to me. The logs show an email being sent at 2019-04-29 10:59:47 to what looks like your email address. Can you double check your spam folders, or other folders that might have auto-categorized the email or marked it as read? If you can't find it, check with whoever runs your mail server / service, as sometimes they need to whitelist VizAlerts-generated mail or it can get filtered out on the server side.

                  • 6. Re: VizAlerts on Tableau Server 2018.3.3
                    Jonathan Drummey

                    Hi Bobby,

                     

                    Once you check the spam folders, etc. as Matt suggested if you're seeing nothing running something else to check is to stop your VizAlerts process in the Task Scheduler, turn on history, restart, and watch what it does. I once had a problem where it looked like VizAlerts wasn't doing anything but there was an error that was only visible in the Task Scheduler history. I can't remember exactly what it was, my memory is that it was some sort of permissions issue or error with the file path that was preventing VizAlerts from running in the first place and updating the VizAlerts log.

                     

                    Jonathan

                    1 of 1 people found this helpful
                    • 7. Re: VizAlerts on Tableau Server 2018.3.3
                      Bobby Reynolds

                      Jonathan,

                      I did review the VizAlerts task in scheduler and you were right, it was having an issue. That is why it appeared that VizAlerts wasn't do anything. So, the issue is fixed and VizAlerts is working. Thanks.