1 2 Previous Next 26 Replies Latest reply on Mar 12, 2020 10:15 AM by Eric Stephens Go to original post
      • 15. Re: tsm maintenance restore fails
        Laura LIMONIER

        Hello guys


        I am facing the same issue, while testing the new 2018.2 version before puting it in production.

        Any insight on this ?


        Thank you !

        Best regards


        • 16. Re: tsm maintenance restore fails
          Dwayne  Bates

          Not sure if anyone is still having this issue. I had the same problem while testing and it was the permissions for users on the folder the backups are in. You have to make sure that the Network Service/Administrators/Specific Users have write access to the folder the backups are in. See below.




          1 of 1 people found this helpful
          • 17. Re: tsm maintenance restore fails
            Alex Eskinasy

            I was having some issues with tsm maintenance restore -f <backup_file_name> , not exactly the same error as the original post, but maybe the root cause is the same.


            When I copied the tsbak file to %ProgramData%\Tableau\Tableau Server\data\tabsvc\files\backups and executed the tsm maintenance restore command from there, it worked!


            Give a shot and let us know if this fixes your issue too.

            1 of 1 people found this helpful
            • 18. Re: tsm maintenance restore fails
              Ken Flerlage

              Dustin, did you ever resolve this? Dealing with the same problem when restoring from 10.4 to 2018.3. Have a case open with Support, but thought I'd check here too.

              • 19. Re: tsm maintenance restore fails
                Ken Flerlage

                For anyone who may be experiencing this issue, I've found a resolution. I can't guarantee this will fix your problem, but it worked for me. First, some background--we're working on migrating a 10.4 instance (on Windows) to a new 2018.3 instance (also on Windows). Everything looked good until we tried to restore our old content to the new one. That's when we ran into these problems. I tried many things, but eventually found the following knowledge base article: https://kb.tableau.com/articles/issue/error-tableau-server-initialization-failed-in-configuration-and-initialization-win… The description is not exactly like my issue, but I tried it anyway. After explicitly setting the permissions for my Run As service account, I was able to perform the restore. I should note that, before finding this, I had tried giving the account temporary local admin privileges, but that did not work. For whatever reason, Windows is being difficult and requires that these rights be granted explicitly to the Run As account. I should also note that I my successful restore was executed without the user being in the local admin group.

                • 20. Re: tsm maintenance restore fails
                  Toby Erkson

                  If you do not see the Security tab and you have admin rights on your computer then open "regedit", go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer, and set the "NoSecurityTab" to zero:

                  Our corporate policy turns off the Security tab (I don't know why).

                  1 of 1 people found this helpful
                  • 21. Re: tsm maintenance restore fails
                    Jeff Strauss

                    We upgraded our prod deployment over the w/e to 2018.3 and ran into several issues with the restore, that we for whatever reason hadn't encountered on dev during testing.


                    Maybe this will help others, so I post here.


                    Issue 1:

                    The tsbak file needs to have security allotted to "Network Service".  We have no idea what this is about and how this account gets automatically added in some tsbak files and some it doesn't.  We were logged in with full admin rights as the runas user and we kept getting "access denied" and the restore would fail right away.  But "Network Service" is def needed.  Perform a Full Backup and Restore of Tableau Server - Tableau


                    Issue 2:

                    There was something confused internally that caused the resotre to keep failing, upon looking in the logs is was trying to access port 8060 of the internal db, but the db wasn't up and therefore the connection was refused.  We never got to the bottom of this one, it was a security related thing, instead we did a full obliterate and started over.  One thought is when we were setting up the coordinate service ensemble, we went too fast (because it was scripted), and the coordination service got uncoordinated.  Per the instructions, you need "several minutes" of wait time to ensure all is setup properly.  Deploy a Coordination Service Ensemble - Tableau  

                    1 of 1 people found this helpful
                    • 22. Re: tsm maintenance restore fails
                      Pooja Lathker

                      Hello Santosh,

                      I am doing a tableau server restore on 2018.2.6 and i have the exact same issue with the same log messages. Can you help me out how you resolved this issue?

                      My Run As user has all the permissions on folder containing the BAckup  file.



                      • 23. Re: tsm maintenance restore fails

                        Pooja Lathker.


                        Its been a while. I do remember reaching out to Tableau Support and Tableau Sales Consultant's but they were not of any help simply because no one could figure out what was happening, ended up delaying the overall upgrade plan. If the below is of any help to you, here it is ..


                        So I had mentioned that I tried 2018.2.1 first on our Tableau Sandbox server, eventually our Sandbox OS was re-imaged from 2012 R2 Standard to 2012 R2 Enterprise because of additional RAM support. Once I had the re-imaged server, I freshly installed 2012.2.1 Tableau Server from scratch ( remember everything was wiped out due to re-image, so no previous installation files or configuration existed ) and configured to match similar to what we had before.


                        I think when I proceeded to do the restore the Prod backup, I succeeded this time.


                        Something with the previous installation was messing with this and I could not figure that out, wasted hours though. I see few more responses to this thread from when I had seen last, not sure if you went through them all. Good luck. Let us know what you ended up doing, if any different then it could be useful next time.



                        • 24. Re: tsm maintenance restore fails
                          Matthew Bonner

                          Just in case anyone stumbles here wondering what else to try, we had to disable the anti-virus on the Tableau directories, as per the instructions found at:


                          • 25. Re: tsm maintenance restore fails
                            Sivasankar Muthusamy



                            I have experienced the same issue with 2019.1.4, the restore was working after clean up the log files.


                            tsm maintenance cleanup -a


                            Also, please verify if there any .tsbak file on the E:\Tableau\Tableau Server\data\tabsvc\files\backups folder ? If there any failure during the restore, then there would be a tsbak file created under this location. Please remove them too.


                            Most of time I experience one or the other problem in restoring the backup and few cases opened with Tableau but I manage to fix them before I hear back from  Tableau support.

                            • 26. Re: tsm maintenance restore fails
                              Eric Stephens

                              This fixed it for me. Thanks Alex

                              1 2 Previous Next