3 Replies Latest reply on Oct 28, 2018 8:51 PM by Jillian Milne


    Jillian Milne

      Hi all


      I am a clinical analyst, analysing procedural data in a hospital.  My work book contains information of the procedures patients had in a given period. 


      I have a dimension titled 'Procedure Category' which returns a string of concatenated procedures e.g. CA;LV;PCI;FFR OR CA;LV, etc  There are many different values in the column, depending on what combination of procedure(s) the patient had.  I want to create a calculated field to identify which patients (rows) had the procedure named FFR in their concatenated result (all the procedure(s) they had.. 


      I have tried several options but I must be doing something really dumb.


      Any help greatly appreciated.





        • 1. Re: FIND TEXT IN A STRING
          Ritesh Bisht

          Hi Jillian,


          It should not be tough ,



          I want only the Directors having/including  name John

          Screen Shot 2018-10-29 at 7.38.56 AM.png



          Screen Shot 2018-10-29 at 7.40.28 AM.png









          Please mark the answer accordingly

          1 of 1 people found this helpful
          • 2. Re: FIND TEXT IN A STRING
            Jillian Milne

            Hi Ritesh


            I agree, it should be straightforward but I am getting errors.  As per the screenshots below, it is saying the field [PROCEDURE CATEGORY] is invalid, but you can see from the column header that it is the correct name of the column.


            I am selecting the field after I type CONTAINS - see orange.  For some reason it is picking up the full name (worksheet, file name) - screenshot 1 which it hasn't done before when I made other calculated fields.  I tried both ways by taking out the excel file name, leaving just the dimension name - screenshot 2, but either way, it doesn't recognise the dimension name.


            • 3. Re: FIND TEXT IN A STRING
              Jillian Milne

              I have solved the problem,  I had an obsolete calculated field called pROCEDURE CATEGORY which it was picking up instead of the dimension I was after so all fixed and working.