1 4 5 6 7 8 Previous Next 143 Replies Latest reply on Apr 7, 2020 10:51 AM by Kent Marten Go to original post
      • 75. Re: Map Utility Downloads
        Richard Leeke



        By the way, I remembered a bit more about what that change in 8.2 was about. The issue was that some shape files use a numeric string as the unique identifier, which could have leading zeros. In order for Tableau to do automatic geocoding on those fields I needed to import the geocoding data with the right number of leading zeros. A change in 8.2 caused Tableau to strip the leading zeros on import, which meant I had to jump through quite a few hoops to get them back. But I completely forgot to allow for spatial file types other than ESRI on that change.


        With the workaround I've given you I think the problem of leading zeros getting stripped might come back for some data sets - though it was a long time ago and I'm hazy on the exact details. That's why it was worth fixing it properly.

        • 76. Re: Map Utility Downloads
          Hock Gan

          Hi Richard,



          I have installed your shapetotab utility (v1.0.11 and tested it with the sample shape file that was included and obtained the results as outlined.

          I then run the utility on the shape file for New Zealand wards from the Department of Statistics ( http//www.stats.govt.nz/browse_for_stats/Maps_and_geography/Geographic-areas/digital-boundary-files.aspx )

          but no files were generated.



          I have attached the relevant files and would appreciate if you can have a look and advise what I need to do to resolve this issue.







          • 77. Re: Map Utility Downloads
            Richard Leeke

            Hmmm - not sure why that wouldn't have worked. I downloaded your shapefile, ran the command and it worked for me.


            There's quite a bit of data so it takes a couple of minutes to extract. What spec is your PC?


            C:\Data\Tableau\Filled Maps\Hock\2016 DB Wards>shapetotab WARD2016_GV_Full.shp

            Generated 239 feature rows for WARD2016_GV_Full

            Generated a total of 1126824 points (min: 90, avg: 4714, max: 310164)

            Overall totals: 239 rows, 1126824 points

            Shape file type: Polygon

            Done in 100 seconds.


            • 78. Re: Map Utility Downloads
              Hock Gan

              Hi Richard,


              My PC spec as follows:

              PC Spec.jpg

              Anyway, I ran the utility today and it worked this time without any problem.


              Thanks again for all your help and the wonderful map utilities that you have created for the Tableau Community.



              • 79. Re: Map Utility Downloads
                Richard Leeke

                Glad it worked.


                That spec should be fine, so I doubt that was the issue - I was just wondering if you had just run it on an old dog of a PC and hadn't been patient enough waiting for it to finish.

                • 80. Re: Map Utility Downloads
                  Jeff Strauss

                  Tableau Desktop 9.2.1 came out, I'm wondering if the fix somehow made it into this release?

                  • 81. Re: Map Utility Downloads
                    Richard Leeke

                    I presume you're talking about the fix for the loss of resolution on small scale imported shapes, are you?


                    I just installed 9.2.1 and (not surprisingly) it's not fixed. I think the release cycle time for maintenance releases is a bit longer than that - and as that fix is only to address an unsupported feature I certainly wouldn't expect it to be rushed in.

                    • 82. Re: Map Utility Downloads
                      Hock Gan

                      Hi Richard,


                      I have downloaded your tabgeohack utility (v2.0.6) and have gone as far as step 5 (--shapes) in working through the commands

                      with your sample data when I came across the "Undefined name" error when I ran the --shape command.


                      Error message 1.jpg


                      When I moved on to step 6 to reopen the workbook and drag the object id onto the level of detail, I encountered

                      the following error message. I presume this is related to the "Undefined name" error in the previous step?

                      Error message 2.jpg

                      Can you advise how I can fix this? I am using Tableau 9.2.





                      • 83. Re: Map Utility Downloads
                        Richard Leeke

                        I vaguely recall seeing an error like that once in the past but can't remember what caused it. Anyway, it's good that it happens with my sample data because that should make it easy for me to reproduce and track down. Maybe I just haven't run that sample data through with Tableau 9.2.


                        I'll try to take a look tonight - failing that it will be after Christmas, I'm away for a few days from tomorrow.

                        • 84. Re: Map Utility Downloads
                          Richard Leeke

                          Well so much for it being easy to reproduce - it works fine for me.


                          I knew I'd seen the error before, though, and sure enough a search of the community site showed up this post from over a year ago: Re: Grow your own Filled Maps.


                          I never really got to the bottom of it. It seemed to be some sort of conflict between something (or some setting) on the particular machine and the version of the Firebird database that Tableau uses for its Geocoding. My last post on the topic was this one: Re: Grow your own Filled Maps in which I suggested that John should try from a different machine. He did try from several machines, all of which failed, but my suspicion was that they were all work machines and there could have been something in the standard build at his site which was conflicting. I did suggest that he tried from a non-work machine, but never heard back.


                          So the best I can do is suggest the same thing for you - try an alternative machine and ideally not one with a similar build.


                          The only other thought is that the issue might be in some way related to language settings. The mention of collations and UTF8 in the error message, plus a vague memory of what the other occurrences of that Firebird error I dug out talked about point me in that direction - but sadly as I can't reproduce it there's nothing I can do to try to diagnose it.


                          Let me know how you get on.

                          • 85. Re: Map Utility Downloads
                            Hock Gan

                            Hi Richard,


                            Thanks for following up. I'll have to put your suggestion on the backburner as I do not have access to an alternative machine at the moment.


                            In the meantime I have to rely on shapetotab to provide the solution to a project I am currently working on. I wish to map the location of Early Childhood Centres

                            in Auckland on the ward boundaries. I tried blending the data from both data sources without any success. I also tried saving the ECE location file in a csv format

                            in the same folder as the features and points folder with the aim of joining the three files but this did not work either.


                            There is probably an obvious solution which which I am am not seeing. I would appreciate if you can have a look at the attached workbook to see if there is a way to

                            combine both maps.





                            • 86. Re: Map Utility Downloads
                              Richard Leeke

                              I'll take a look and see if I have any ideas.


                              I can also import the ward boundaries as custom geocoding for you if you like, to get around that issue you're hitting. Do you just want Auckland wards, or shall I do the whole country?

                              • 87. Re: Map Utility Downloads
                                Hock Gan

                                Hi Richard,


                                Thanks for your offer.


                                In addition to the wards, I would like to be able to drill down my analysis

                                to individual census area units. Can you therefore

                                import both the ward and census area units as custom geocoding for the

                                whole country? It will be helpful if I can overlay the area unit

                                boundaries over ward boundaries.




                                On 25 December 2015 at 16:39, Richard Leeke <

                                • 88. Re: Map Utility Downloads
                                  Richard Leeke

                                  OK, I've imported Wards and Area Units for you.


                                  I used the Dept of Statistics "New Zealand 2016 clipped generalised" data set (meaning it excludes territorial waters and it is slightly lower resolution and therefore smaller and faster than the high definition set). For your purposes that seemed the most useful.


                                  I've attached a packaged workbook with your ECE data that includes the custom geocoding. If you want to use that custom geocoding for other analysis you can just copy the "Local Data" directory out of the packaged workbook and drop it inside your Tableau Repository as shown in the screen shot. (A packaged workbook is really just a ZIP file, so you can open it with any zip utility and extract the contents.)




                                  That will then be available for any other workbooks. Note that I purged all of the standard Tableau geocoding to keep the packaged workbook size down, so while that is in play you won't be able to see any of the standard Tableau filled maps. Just remove it if you want standard Tableau maps back.


                                  I set the workbook up as a dual axis view showing the locations of the institutions overlaid on Wards. Just add Area Units to the colour shelf for the "Filled Map" Latitude axis if you want to show Area Units.


                                  I've also attached the YML definition I used for tabgeohack - just in case you do manage to get it to work on your machine, so you can see exactly how I set it up.


                                  Let me know if you have any problems.

                                  1 of 1 people found this helpful
                                  • 89. Re: Map Utility Downloads
                                    Hock Gan

                                    Hi Richard,


                                    Thanks for your help.


                                    When I added Area Units onto the colour shelf, it appears that a number of Area Units have not been geo-coded as shown

                                    in the white regions on the map below. These regions do not have any tooltip details.


                                    Area units - tabgeohack.jpg


                                    To test whether this was an issue with the data source, I created the map using shapetotab and the geocoding

                                    appears to be working properly as shown in the image below.


                                    Area units - shapetotab.jpg


                                    I would appreciate if you can have a look at this.


                                    Thanks again



                                    1 4 5 6 7 8 Previous Next