7 Replies Latest reply on Nov 6, 2015 6:57 AM by Simon Horne

    Tableau Server Backup Permissions issues with Task Scheduler

    Simon Horne

      Hi I am trying to schedule regular backups using the Task scheduler.  However I am encountering problems which seem to point to UAC problems


      To create the Backup task I have taken the following steps


      I logon to the Tableau server with an domain admin account that has administrator privileges on the server, whilst logged on with this account

      • I ensure that the permissions of the Account that Tableau is running under has
        • Allow Log on as a Service (additionally that the account is not included as Deny Log on as Service)
        • Allow Log on as a Batch Job (additionally that the account is not included as Deny Log on as Batch Job)
        • Allow Log on Locally (additionally that the account is not included as Deny Log on Locally)
        • Full permissions to the folder the backup is saving to
      • I Open the Task scheduler with right click "Run as Administrator"
      • I Create a new Task with the following settings




      • I create a task to call the tabadmin command.  I have tried both of the following
        • Calling the Tabadmin command directly with "Backup d:\backuplocation\file.tsback -d"
        • Calling a batch file which runs the above
      • I set the following settngs (I have tried "Stop the existing instance" and "Do nothing"  for the option if a task is already running




      • When I click OK, I am prompted for the password for the Tableau service account which I am reasonably sure is correct
      • I have then tried both scheduling and manually running the job, but I always receive the following
      • ts3.JPG
      • Doing some googling on Task Scheduler return codes  - 2147943859 would seem to translate as ERROR_ELEVATION_REQUIRED


      Additionally if I set the task to run under a different account that has local administrator privileges - the Task runs successfully and without issue


      Has anyone encountered this issue else been able to resolve this?