1 Reply Latest reply on Aug 13, 2015 2:43 PM by alex macharia

    ODBC Greenplum error (dates not working)

    Janos Ijgyarto

      Hi everyone. I'm using ODBC DataDirect to connect to a database in Greenplum, but for some reason Tableau keeps running into an error when interpreting the dates. For example, if I try to use a date field as a filter, I can only use "Range of Dates" and have it work without errors. If I try to use a non-continuous format (e.g years), I get the following error:


      "[DataDirect][ODBC Greenplum Wire Protocol driver][Greenplum]ERROR: function trunc(double precision, integer) does not exist(Hint No function matches the given name and argument types. You may need to add explicit type casts.;Position 227;File parse_func.c;Line 331;Routine ParseFuncOrColumn;)"


      The same error pops up whenever I try to simply view the data. If I try to change the data type to string, this pops up:


      "[DataDirect][ODBC Greenplum Wire Protocol driver][Greenplum]ERROR: cannot cast type pgsapam.t_pg_apps_detailed to character varying(Position 582;File parse_expr.c;Line 2753;Routine typecast_expression;)"


      We tried changing the format of the dates in the table itself, but the same errors keep popping up.


      Anyone have any suggestions? Thanks in advance!


      EDIT: I'm using Tableau version 9.0