1 22 23 24 25 26 Previous Next 516 Replies Latest reply on May 24, 2017 11:30 AM by Minh Nguyen Go to original post
      • 345. Re: Grow your own Filled Maps
        Richard Leeke

        Just realised that the reason for the behaviour Juracy was seeing the other day was slightly different from how I described it.

         

        Actually what is happening is that in 8.1, both the geocoding database and the Excel query were treating ESTADO as string.

         

        In 8.2, both geocoding and a query using the new connector treat ESTADO as numeric - so it is offerered as a matching geographic role.

         

        But if you use the legacy connector (needed for custom SQL), the query returns it as a string whilst the geocoding import has made it a number - hence the mismatch.

         

        That makes much more sense than what I said before - it's because 8.2 is doing a better job of the data type detection (unless you fall back to the legacy connector).

        • 346. Re: Grow your own Filled Maps
          Juracy Americo

          Great Richard, I gonna try it now....

           

          hey I thing you mean version 2.0.1 right instead.

          • 347. Re: Grow your own Filled Maps
            Richard Leeke

            2.0.1 indeed (fixed in the above comment). Thanks for that.

             

            You shouldn't see any difference from 2.0.0 if you weren't hitting the problem I hit - so if you do it probably means I've broken something else. Should be fine, I ran a large test with a lot of different shape files...

            • 348. Re: Grow your own Filled Maps
              Juracy Americo

              Hi , now is ok.

               

              The Estado field is interpret as a numeric instead of string and I can see the geographic role Estado.

              Work perfect.

               

              Thank for the attention you give to that tool, it is brilliant.

               

              Have a nice week,

              • 349. Re: Grow your own Filled Maps
                Angie Greenhaw

                Hi Richard,

                 

                Thanks for creating this tool -- it's pretty slick! I'm running into an issue when I try to import my custom geocoded CSV file into Tableau:

                 

                Error at end of import.jpg

                 

                I clicked Yes at the prompt above, thinking it might be ok...but when I issued the tabgeohack --shapes USACE_Districts.yml command I got the following:

                 

                Error at shape generation attempt.jpg

                 

                Any idea as to what I might be doing wrong? Also, this shape file uses multipolygons -- would that make a difference? Any info would be really helpful. Thanks so much in advance!

                 

                Angie Greenhaw

                • 350. Re: Grow your own Filled Maps
                  Richard Leeke

                  I used to know exactly what that first error (the one on importing the custom geocoding) meant - but it's a long time since I've done much with this and I can't remember the precise details.

                   

                  As I recall, that is Tableau trying to figure out how to associate District into it's geocoding hierarchy (Country->State->City... etc) at the right level. It is not managing to find some columns that it thinks it needs in your Districts file.

                   

                  If you are able to post a copy of your YAML file (USACE_Districts.yml) and either a copy of the custom gecoding CSV files or at least the column names and a few sample lines, I'll probably be able to remind myself what it is up to.

                   

                  I'm fairly sure it will just be a matter of adjusting the YAML file slightly - possibly by aliasing some column names or something.

                   

                  I'll also look back through my emails to when I was first putting this together - I'm fairly sure I remember that one of the "beta testers" hit the same thing...

                   

                  The error on the --shapes step in tabgeohack is just because the import of custom geocoding didn't work. The prompt asking if yiu want to keep what it has done is because you might have had several geographic roles that you were trying to import and only one of them had failed, so it would let you keep the ones that succeeded.

                   

                  Multipolygons are supported and work fine.

                  • 351. Re: Grow your own Filled Maps
                    Angie Greenhaw

                    Richard,

                     

                    Thank you so much for your response. I've attached 2 YML files I've tried here -- one keeps the standard Tableau hierarchy and the other tries to substitute in a new hierarchy since there are several districts within each division (and I thought removing the reference to Country and State might help). But no dice -- both result in the same error when I try to import the generated CSV into Tableau. Also, I attached a copy of the CSV file that is being generated (subbing in dummy data).

                     

                    Any suggestions would be most helpful, thanks again!

                     

                    Best,

                    Angie Greenhaw

                    • 352. Re: Grow your own Filled Maps
                      Richard Leeke

                      Well I know what you need to to to get past the problem - but I'm guessing a bit what Tableau is doing.

                       

                      It seems to be thinking that the "District" column corresponds to one of the built-in geographic role which sits below State in the geocoding hierarchy - which is why it is saying you need to supply Country and State. Looking at the geocoding hierarchy as I've got it defined in the YAML file:

                       

                      role_hierarchy:

                          -  role: Country

                              children:

                                  -  role: State

                                      children:

                                          -  role: City

                                          -  role: County

                                          -  role: Congress

                                  -  role: ZipCode

                                  -  role: AreaCode

                                  -  role: CMSA

                       

                      there are 3 possibilities and I'm guessing it is assuming it is a Congressional District - though there is nothing in the documentation that suggests that that would happen and also as far as I can see the internal tables it uses for automatically assigning geographic roles wouldn't treat a column called "District" as a congressional District.

                       

                      Anyway - all you need to do to get around it is change the name of the column. I just made it DistrictX - but I'm sure you can use something meaningful. You just need to set that as the alias for that column in the YAML file.

                       

                      By the way - I noticed from your YAML file that you don't have Congress defined in the hierarchy. I'm guessing that means you downloaded tabgeohack a long time ago - Congressional Districts have been there for a long time. It's probably worth getting the latest version from here and updating your YAML files to include that - though it only has any impact if you use the purging feature to cut down the size of the geocoding database (which is worthwhile if you create packaged workbooks or publish on Public), Watch out for the two versions, BTW - the old version only works up to Tableau 8.1 and the new version only works from Tableau 8.2.

                      • 353. Re: Grow your own Filled Maps
                        Angie Greenhaw

                        Wow, I would have never guessed that an alias named "District" was being perceived as "Congressional District" (or would otherwise cause an issue)! That must have been it because after changing the alias I'm able to import the file with zero errors and can render the shapes using the filled map chart type. Excellent!

                         

                        I have actually already upgraded to the newest tabgeohack version -- I actually did that last week after getting a "Firebird release not supported" error. I must have kept the old copy of my YAML file which I'd previously been using before the upgrade which didn't include role: Congress.

                         

                        Thank you so much for your input, very helpful!

                         

                        Best,

                        Angie Greenhaw

                        • 354. Re: Grow your own Filled Maps
                          Richard Leeke

                          Glad it's working. Thanks for reporting back, I'm always interested to know if the issue was fixed.

                          • 355. Re: Grow your own Filled Maps
                            John Sieglaff

                            Good afternoon (well, it's afternoon here in Iowa) Richard/everyone.

                             

                            I am trying to use this tool, as we break up counties our sales people work in by township. I am attempting to work through your example in the PDF document included with Tab Geo Hack, and I keep getting the following error during the Shapes portion:

                             

                            @@C:\Data\Tableau\TabGeoHack>tabgeohack --roles "Porirua Tsunami Warnings.yml"

                            Generating custom geocoding files...

                                Porirua_Meshblock... (602)

                                Porirua_Tsunami... (3)

                            Done in 1 seconds

                             

                            C:\Data\Tableau\TabGeoHack>tabgeohack --shapes "Porirua Tsunami Warnings.yml"

                            Generating shapes...

                            Use of uninitialized value $lat in concatenation (.) or string at tabgeohack.pl

                            line 1190, <BOUND> line 375.

                                Porirua_Meshblock... added 602 rows with a total of 18077 points (min: 5, av

                            g: 30, max: 207)

                            Use of uninitialized value $lat in concatenation (.) or string at tabgeohack.pl

                            line 1190, <BOUND> line 3.

                            Use of uninitialized value $lat in concatenation (.) or string at tabgeohack.pl

                            line 1190, <BOUND> line 4.

                                Porirua_Tsunami... added 3 rows with a total of 620 points (min: 206, avg: 2

                            06, max: 207)

                            Overall totals: 605 rows, 18697 points

                            Purging unwanted geocoding data...

                            Processing role: Country

                                             - Keeping: 'New Zealand', 'Australia'

                            Processing role:   State

                                               - Keeping: 'Wellington'

                            Processing role:     City

                            Undefined name

                            -COLLATION UNICODE_CI for CHARACTER SET UTF8 is not installed at tabgeohack.pl l

                            ine 1373

                             

                            C:\Data\Tableau\TabGeoHack>

                             

                            Any idea what could be causing this?

                             

                            Also, the files I will be using for the townships, do not have state name or county name, just the FIPS code...do I need to translate those into the proper state/county textual names?

                            • 356. Re: Grow your own Filled Maps
                              Luís Ramos

                              Hi Richard Leeke,

                               

                              First of all, congratulations for this hard work that you've been doing with tabgeohack and shapetotab!

                              I tried create a shapefile of roads in Tableau 8.2 using Shapetotab 1.0.10.

                               

                              I used the command 'shapetotab --precision 11 REDE_CALIBRADA_EP.shp' and I got this:

                              1.png

                              Then when I open in Tableau 8.2 I did that:

                              2.png

                               

                              Finally:

                              3.png

                              What I'm doing wrong?

                               

                              Cumpz,

                              Luís Ramos

                              • 357. Re: Grow your own Filled Maps
                                Richard Leeke

                                Hi John

                                 

                                Well I really don't know what is causing that. The error about $lat being undefined implies that one row in the meshblocks file and 2 rows in the tsunami warning zones file don't have a valid lat/long defined. The internal file format holds longitude and latitude in a single string field, separated by a space. I then split that into two fields based on the space. The only way I could see that happening is if the space wasn't recognised.

                                 

                                I'm puzzled by the warning about the missing collation - I don't know what that means. Just possibly the file has a few rows which use a different character for the space which needs a certain collation to be defined for it be recognised - but that all sounds very tenuous to me. But on the other hand - those example files are unchanged since I first shared the tool two and a half years ago and you are the only person to have the issue.

                                 

                                It sounds hard to dig into this - so I can't promise if or when I'll get to take a look.

                                • 358. Re: Grow your own Filled Maps
                                  Richard Leeke

                                  Hi Luis

                                   

                                  The trouble is I haven't added support for MULTILINESTRING - I'd never even heard of that format.

                                   

                                  If you could post a copy of your shapefile I can take a look sometime (not sometime soon though!).

                                   

                                  Richard

                                  1 22 23 24 25 26 Previous Next