1 Reply Latest reply on Nov 11, 2013 9:08 AM by Michel Roberge

    Web Authoring with Sites and Trusted Authentication yields a 404 page not found

    Michel Roberge

      Hi guys,


      I am using our own OEM build of the Server, version 8.0.3.


      I have some code to return a URL to view a workbook. The end URL is like this:


      http://<Ip Address>:<Port>/trusted/<Ticket#>/t/<Site>/views/<workbook>/<worksheet>


      And it works fine.


      I changed my code so it would replace "/views/" with "/authoring/" so instead,  I would get this:


      http://<Ip Address>:<Port>/trusted/<Ticket#>/t/<Site>/authoring/<workbook>/<worksheet>


      Now I get a 404 page not found.


      What is strange, is if I go through the login process instead of trusted auth, and navigate to that workbook for editing, the end Url is this:


      http://<Ip Address>:<Port>/t/<Site>/authoring/<workbook>/<worksheet>/<worksheet>


      And editing does work thus.


      So of course, the first thing I tried was to add /<worksheet> again like this:


      http://<Ip Address>:<Port>/trusted/<Ticket#>/t/<Site>/authoring/<workbook>/<worksheet>/<worksheet>


      But I got 404 again.


      Does anyone know what I could be doing wrong? I've tried multiple different combination, but I couldn't fathom what is wrong.