13 Replies Latest reply on Jan 7, 2020 8:26 AM by Joe Oppelt

    Tableau error - Cannot blend the secondary data source because one or more fields use an unsupported aggregation

    Eva K

      I read through this thread but I didnt get any solution for my issue, that's why I thought of opening a new thread.

       

      Cannot blend the secondary data source because one or more fields use an unsupported aggregation

       

      Here's what I am trying to do, we have almost 2 months lag when we get the data, e.g. we will get the Jan 2020 data in late February. So to account for that and not show a blank dashboard for YTD metrics, I tweaked my current year calculation. So, what this will do is, until we get the Jan 2020 data, it will show 2019 full year as for YTD metrics and as soon as we start getting Jan 2020 data, it will start showing the 2020 data as YTD.

       

       

      so, the commented out calculated field is the older version, and to calculate the Max FullDate, I am creating an LOD calculation.

       

       

      But looks like, this LOD is messing up with the blended data source and I get the error mentioned above in the title. If I use the commented out calc field for 'Current Year' then my workbook works fine but then my dashboard will be blank on Feb 1st.

       

      The reason I can't join the 2 data sets because the level of detail for both is different.

       

      I have attached the twbx file, version: 2019.2

       

       

      Jonathan Drummey