5 Replies Latest reply on Jan 24, 2020 4:23 AM by Pooja Sarnaik

    test with test_alert comment failed

    Bruce liu

      VizAlerts 2.1.1

      tableau server 2019.3

      simple Scheduled alerts have been successful

      but i enter a comment "test_alert" and the VizAlertsConfig list have the record,

      when I run vizalerts.exe, nothing happens. and i run it again ,nothing hapens.

        • 1. Re: test with test_alert comment failed
          Matt Coles

          Hi Bruce, could you share the log file from your last run, please? Be sure to redact any sensitive information before doing so, such as server names, IP addresses, etc.

          • 3. Re: test with test_alert comment failed
            Matt Coles

            Okay, so it's not picking up that any work needs to be done. Try the following:

             

            1. Load your VizAlertsConfig/ScheduledTriggerViews. Then, add a "test_alert" comment directly to it. Refresh the view using the button.
            2. Check that a new record appears in the viz.
              1. If it does not, then:
                1. Ensure that the connection in the viz points to the right PostgreSQL repository server.
                2. Check that you have not inadvertently excluded the viz by using a "Keep Only" or some other filter.
              2. If it does, then:
                1. Check your config\vizalerts.yaml file and ensure that you're pointing to the same Tableau Server instance that you added the comment to, for the "server:" property.
            • 5. Re: test with test_alert comment failed
              Pooja Sarnaik

              Hello Bruce

               

              As this thread is bit older you might have resolved the issue.If not, this may help you.

               

              As per my understanding..

              From the attached screenshot, in the VizalertsConfig workbook there in one entry of View named - Advanced Alerts Demo 3.

              In this view you can see the subscription_id as negative number.Negative ID is displayed when you hit the comment "test_alert".However there is no main entry of the view "Advanced Alerts Demo 3",as there is no positive id assigned to that view.

              You may need to check the subscription of that view and the schedule used is disabled.

               

              There must be one entry of the view (in your case Advanced Alerts Demo 3) with positive Subscription ID in VizalertsConfig/ScheduledTriggerView.

              And then when you run the "test_alert" comment on the view  Advanced Alerts Demo 3,the temporary negative Subscription ID is created for the same view.(You may require to refresh VizalertsConfig/ScheduledTriggerView workbook)

               

              Hope this helps.